summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2016-03-18 22:44:36 +0800
committerMatt Johnston <matt@ucc.asn.au>2016-03-18 22:44:36 +0800
commit8c53621c24bf29eaef1f60bc35d6780cb092c338 (patch)
treeb3d9025b7c1ce1dcbbf9168bf7e5fbac027dab51
parent514baf3bf7f002f364f35db65081b421d854d7b9 (diff)
downloaddropbear-DROPBEAR_2016.73.tar.gz
-rw-r--r--CHANGES15
-rw-r--r--debian/changelog6
-rw-r--r--sysoptions.h2
3 files changed, 20 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 6174a09..ceb01be 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,4 @@
-- Fix crash when fallback initshells() is used, reported by Michael Nowak and Mike Tzou
+2016.73 - 18 March 2016
- Support syslog in dbclient, option -o usesyslog=yes. Patch from Konstantin Tokarev
@@ -9,14 +9,25 @@
- New "-o" option parsing from Konstantin Tokarev. This allows handling some extra options
in the style of OpenSSH, though implementing all OpenSSH options is not planned.
-- Various cleanups for issues found by a lint tool, patch from Francois Perrad
+- Fix crash when fallback initshells() is used, reported by Michael Nowak and Mike Tzou
- Allow specifying commands eg "dropbearmulti dbclient ..." instead of symlinks
+- Various cleanups for issues found by a lint tool, patch from Francois Perrad
+
- Fix tab indent consistency, patch from Francois Perrad
- Fix issues found by cppcheck, reported by Mike Tzou
+- Use system memset_s() or explicit_bzero() if available to clear memory. Also make
+ libtomcrypt/libtommath routines use that (or Dropbear's own m_burn()).
+
+- Prevent scp failing when the local user doesn't exist. Based on patch from Michael Witten.
+
+- Improved Travis CI test running, thanks to Mike Tzou
+
+- Improve some code that was flagged by Coverity and Fortify Static Code Analyzer
+
2016.72 - 9 March 2016
- Validate X11 forwarding input. Could allow bypass of authorized_keys command= restrictions,
diff --git a/debian/changelog b/debian/changelog
index 9a3d08e..9669e2a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dropbear (2016.73-0.1) unstable; urgency=low
+
+ * New upstream release.
+
+ -- Matt Johnston <matt@ucc.asn.au> Fri, 18 Mar 2016 22:52:58 +0800
+
dropbear (2016.72-0.1) unstable; urgency=low
* New upstream release.
diff --git a/sysoptions.h b/sysoptions.h
index 8ce4361..9a76655 100644
--- a/sysoptions.h
+++ b/sysoptions.h
@@ -4,7 +4,7 @@
*******************************************************************/
#ifndef DROPBEAR_VERSION
-#define DROPBEAR_VERSION "2016.72"
+#define DROPBEAR_VERSION "2016.73"
#endif
#define LOCAL_IDENT "SSH-2.0-dropbear_" DROPBEAR_VERSION