summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChmouel Boudjnah <chmouel@chmouel.com>2012-05-23 15:14:47 +0200
committerChmouel Boudjnah <chmouel@chmouel.com>2012-06-07 12:06:28 +0200
commitdec11f6ec913e6874668c67e5643b81e0014f723 (patch)
tree5eed5c43c23d04100956115f41cafc630b559a6d /setup.py
parentb13823ef1847131399d69789738e0fe2aaac1ac6 (diff)
downloadpython-swiftclient-dec11f6ec913e6874668c67e5643b81e0014f723.tar.gz
Add doc and version in swiftclient.__init__.py
- Add parseable version in swiftclient.__init.py - Generate rst doc like done for swift. Change-Id: I408fbc36693772d2ef6f4823757dd1f4c830193f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d70a473..2c5e8e5 100644
--- a/setup.py
+++ b/setup.py
@@ -20,10 +20,11 @@ import setuptools
import sys
from swiftclient.openstack.common import setup
+from swiftclient import version
# TODO: Figuring out how we are going to do the versioning (and if
# any).
-version = '1.1'
+version = version
name = 'python-swiftclient'
requires = setup.parse_requirements()