summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-12-27 15:26:50 -0800
committerMonty Taylor <mordred@inaugust.com>2013-01-18 16:13:27 -0500
commitbfeffb63667b796999997acf43be395d31b6a184 (patch)
tree03a4d4ea649f4a0c8373830d06023ea5a3dfa660 /setup.py
parent1aa712eaf224efcb575dd76c546adce810b1b2f4 (diff)
downloadpython-swiftclient-bfeffb63667b796999997acf43be395d31b6a184.tar.gz
Use testr instead of nose.
nose is invasive and can sometimes alter the outcome of a test run. testr, on the other hand, keeps a distinction between running tests and displaying results of the test runs. Additionally, it supports the stock python unittest protocol. Even better, testr supports parallel test running, which makes things faster, and a command "testr run --failing" which will just re-run the latest failing tests (often something one wants to do in iterative dev) Part of blueprint grizzly-testtools Change-Id: I0b3f1bcb5d4ff59c65eb3219b30a9e64f54d70bd
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9de50ab..beb6c23 100644
--- a/setup.py
+++ b/setup.py
@@ -54,7 +54,6 @@ setuptools.setup(
'Programming Language :: Python :: 2.6',
'Environment :: No Input/Output (Daemon)',
],
- test_suite='nose.collector',
scripts=[
'bin/swift',
],