summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChmouel Boudjnah <chmouel@chmouel.com>2012-05-08 11:17:04 +0100
committerChmouel Boudjnah <chmouel@chmouel.com>2012-05-08 13:09:17 +0100
commitb55acc34f0df54a48665eb3fbc7d9eb024dd7cb2 (patch)
treef2827325ace0f7aa2fad7208fcf59d2506d0eb84 /setup.py
downloadpython-swiftclient-b55acc34f0df54a48665eb3fbc7d9eb024dd7cb2.tar.gz
First commit.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..309a241
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+# -*- encoding: utf-8 -*-
+import os
+import setuptools
+import sys
+
+# TODO: Figuring out how we are going to do the versionning (and if
+# any).
+version = '0.1'
+name = 'python-swiftclient'
+requires = []
+
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+if sys.version_info < (2, 6):
+ requires.append('simplejson')
+
+setuptools.setup(
+ name=name,
+ version=version,
+ description='Client Library for OpenStack Object Storage API',
+ long_description=read('README.rst'),
+ url='https://github.com/chmouel/python-swiftclient',
+ license='Apache License (2.0)',
+ author='OpenStack, LLC.',
+ author_email='openstack-admins@lists.launchpad.net',
+ packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
+ install_requires=requires,
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2.6',
+ 'Environment :: No Input/Output (Daemon)',
+ ],
+ test_suite='nose.collector',
+ scripts=[
+ 'bin/swift',
+ ],
+)