summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-06-25 11:10:02 -0500
committerMonty Taylor <mordred@inaugust.com>2012-06-26 21:23:25 -0500
commit51bceabd18b04a5663584a054322c9a04fcc29db (patch)
treef175b97bdc551774d8785f3c0b9222ea6f26bd3c /setup.py
parent3a11e185b38da452cb952c63acc8c5e33a924748 (diff)
downloadpython-swiftclient-51bceabd18b04a5663584a054322c9a04fcc29db.tar.gz
Add post-tag versioning.
Change-Id: Id921105dd2fa818cac7c66dc620b266fd5639d72
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 1 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2c5e8e5..235a0f8 100644
--- a/setup.py
+++ b/setup.py
@@ -20,11 +20,7 @@ import setuptools
import sys
from swiftclient.openstack.common import setup
-from swiftclient import version
-# TODO: Figuring out how we are going to do the versioning (and if
-# any).
-version = version
name = 'python-swiftclient'
requires = setup.parse_requirements()
@@ -36,7 +32,7 @@ def read(fname):
setuptools.setup(
name=name,
- version=version,
+ version=setup.get_post_version('swiftclient'),
description='Client Library for OpenStack Object Storage API',
long_description=read('README.rst'),
url='https://github.com/openstack/python-swiftclient',