summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStephen Finucane <stephenfin@redhat.com>2022-02-17 11:21:40 +0000
committerTim Burke <tim.burke@gmail.com>2022-03-16 15:06:19 -0700
commit2636965f38a7788bbee19fc90088384834670b10 (patch)
treeba693b60748bdcea934e6a8434b158bc7fadeb91 /setup.py
parent22a05b2039d0178b52fa3546de8ab265df112636 (diff)
downloadpython-swiftclient-2636965f38a7788bbee19fc90088384834670b10.tar.gz
Drop support for Python 2
There's a lot of cleanup possible, but this is a start. Signed-off-by: Stephen Finucane <stephenfin@redhat.com> Change-Id: Ia1176b7fd5434d52070d482a37abfbb98800cdb3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 2 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 16a18f6..22cfdce 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -14,12 +14,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
-import setuptools, sys
-
-if sys.version_info < (2, 7):
- sys.exit('Sorry, Python < 2.7 is not supported for'
- ' python-swiftclient>=3.0')
+import setuptools
setuptools.setup(
setup_requires=['pbr'],