summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorChristian Schwede <christian.schwede@enovance.com>2014-02-26 09:52:38 +0000
committerChristian Schwede <christian.schwede@enovance.com>2014-03-25 11:32:51 +0000
commit100419c0b3443419b942d44e6e9d04ae6122678c (patch)
tree0075ab278270bb28ccab42cfad4649a226b541c9 /setup.cfg
parent070dd48c315b63e9ba75fc1020922222c985b194 (diff)
downloadpython-swiftclient-100419c0b3443419b942d44e6e9d04ae6122678c.tar.gz
Make bin/swift testable part 1
To make bin/swift importable for testing it needs to be renamed/moved. The final idea is to move it to swiftclient/shell.py and add only a stub in bin/swift to import swiftclient/shell.py. However, doing this in a single step makes reviewing very hard, because now there are > 1400 lines deleted from bin/swift and added to swiftclient/shell.py - Gerrit doesn't detect the moved file. For example: https://review.openstack.org/#/c/73710/2/ This patch first moves the code to swiftclient/shell.py and uses setup.py/cfg to create the stub file in bin/swift. A follow up (https://review.openstack.org/#/c/76489/) will then add the stub itself in bin/swift (and remove the entry in setup.py). The change to tox.ini is related to bug 1290562 and can be removed in the future. Change-Id: Id86392ccaf09e1d80a5d808fb49827d6d18c2588
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.cfg b/setup.cfg
index a7f8c2d..1eaf9ff 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -24,11 +24,13 @@ setup-hooks =
[files]
packages =
swiftclient
-scripts =
- bin/swift
data_files =
share/man/man1 = doc/manpages/swift.1
+[entry_points]
+console_scripts =
+ swift = swiftclient.shell:main
+
[build_sphinx]
source-dir = doc/source
build-dir = doc/build