summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKiall Mac Innes <kiall@managedit.ie>2012-11-19 23:08:35 +0000
committerKiall Mac Innes <kiall@managedit.ie>2012-11-27 15:46:32 +0000
commit6f280a8693c2039ce4353cf65046858cf28fcff6 (patch)
tree98efc2727072df18f5ed07dc33f3f55a79369a90 /setup.py
parentfd06cdfad06caa7a46ea848178b945c86cb428d1 (diff)
downloadpython-designateclient-6f280a8693c2039ce4353cf65046858cf28fcff6.tar.gz
Initial Python client bindings and CLI
Change-Id: Iac4a73acfb515c1e213a1dd0865a62bc39e3ed0f
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index bd6e49d..1e76ba9 100755
--- a/setup.py
+++ b/setup.py
@@ -14,6 +14,7 @@
# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
# License for the specific language governing permissions and limitations
# under the License.
+import textwrap
from setuptools import setup, find_packages
from monikerclient.openstack.common import setup as common_setup
from monikerclient.version import version_info as version
@@ -46,6 +47,14 @@ setup(
'bin/moniker',
],
cmdclass=common_setup.get_cmdclass(),
+ entry_points=textwrap.dedent("""
+ [moniker.cli]
+ domain-list = monikerclient.cli.domains:ListDomainsCommand
+ domain-get = monikerclient.cli.domains:GetDomainCommand
+ domain-create = monikerclient.cli.domains:CreateDomainCommand
+ domain-update = monikerclient.cli.domains:UpdateDomainCommand
+ domain-delete = monikerclient.cli.domains:DeleteDomainCommand
+ """),
classifiers=[
'Development Status :: 3 - Alpha',
'Topic :: Internet :: Name Service (DNS)',