summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-07-01 13:11:43 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-07-01 13:11:43 +0000
commit572689658566690e5861bea2cd45ed9c955e183e (patch)
tree7a1a9574e58d8168b53715f13db0c52343032309 /setup.py
parent469afe148209c1c9e9e9dc1c67aff4dac5489131 (diff)
downloadpython-designateclient-572689658566690e5861bea2cd45ed9c955e183e.tar.gz
Updated from global requirements
Change-Id: Ia126b95d6673ad73ad9f377c638a022e2b485799
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)