summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-04 12:36:36 +0200
committerAndreas Jaeger <aj@suse.com>2020-04-04 12:39:05 +0200
commit9a2f2d4b9caea39ec82823a8d9187f7ddd21aeab (patch)
tree698c1d49002823c5755dfcd4dbbda3e71512dfa7 /setup.cfg
parentb9bcae014013834bc72dc5a490eeae4876eda764 (diff)
downloadpython-designateclient-9a2f2d4b9caea39ec82823a8d9187f7ddd21aeab.tar.gz
Cleanup py27 supportussuri-em4.0.0
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo * Some other sections are obsolete - Update classifiers - Update requirements, no need for python_version anymore - Remove html_last_updated_fmt from conf.py, this is not needed with openstackdocstheme anymore; update openstackdocstheme requirement Change-Id: I5389ba08c985e023643c07adf3135809c291146f
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg18
1 files changed, 3 insertions, 15 deletions
diff --git a/setup.cfg b/setup.cfg
index 5686bf2..67d622e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -7,6 +7,7 @@ license = Apache License, Version 2.0
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/python-designateclient/latest
+python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -14,15 +15,13 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Topic :: Internet :: Name Service (DNS)
-[global]
-setup-hooks =
- pbr.hooks.setup_hook
-
[files]
packages =
designateclient
@@ -100,14 +99,6 @@ openstack.dns.v2 =
tsigkey_set = designateclient.v2.cli.tsigkeys:SetTSIGKeyCommand
tsigkey_delete = designateclient.v2.cli.tsigkeys:DeleteTSIGKeyCommand
-
-[build_sphinx]
-builders = html,man
-all-files = 1
-warning-is-error = 1
-build-dir = doc/build
-source-dir = doc/source
-
[egg_info]
tag_build =
tag_date = 0
@@ -127,9 +118,6 @@ keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg
output_file = designateclient/locale/designateclient.pot
-[wheel]
-universal = 1
-
[pbr]
autodoc_index_modules = True
api_doc_dir = reference/api