summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-05 17:40:33 +0200
committerAndreas Jaeger <jaegerandi@gmail.com>2020-04-17 12:04:22 +0000
commit0ef60e6249e0bc41ab3c29fc9cbc86fe17808765 (patch)
tree9e400e14ac7abf6023598f074bd3de6bc8d15ae2 /setup.py
parentfd0db53db1b22ba1df239dc2978c192361dd8244 (diff)
downloados-client-config-0ef60e6249e0bc41ab3c29fc9cbc86fe17808765.tar.gz
Cleanup py27 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.5 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg - Update classifiers Depends-On: https://review.opendev.org/718068 Change-Id: I55b4938edae85aa8108be62c49f0ac7fc6682997
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 566d844..cd35c3c 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)