summaryrefslogtreecommitdiff
path: root/vendor/tornado/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/tornado/setup.py')
-rw-r--r--vendor/tornado/setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/vendor/tornado/setup.py b/vendor/tornado/setup.py
new file mode 100644
index 0000000000..5cb69df2da
--- /dev/null
+++ b/vendor/tornado/setup.py
@@ -0,0 +1,44 @@
+#!/usr/bin/env python
+#
+# Copyright 2009 Facebook
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may
+# not use this file except in compliance with the License. You may obtain
+# a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations
+# under the License.
+
+import distutils.core
+import sys
+# Importing setuptools adds some features like "setup.py develop", but
+# it's optional so swallow the error if it's not there.
+try:
+ import setuptools
+except ImportError:
+ pass
+
+# Build the epoll extension for Linux systems with Python < 2.6
+extensions = []
+major, minor = sys.version_info[:2]
+python_26 = (major > 2 or (major == 2 and minor >= 6))
+if "linux" in sys.platform.lower() and not python_26:
+ extensions.append(distutils.core.Extension(
+ "tornado.epoll", ["tornado/epoll.c"]))
+
+distutils.core.setup(
+ name="tornado",
+ version="0.2",
+ packages = ["tornado"],
+ ext_modules = extensions,
+ author="Facebook",
+ author_email="python-tornado@googlegroups.com",
+ url="http://www.tornadoweb.org/",
+ license="http://www.apache.org/licenses/LICENSE-2.0",
+ description="Tornado is an open source version of the scalable, non-blocking web server and and tools that power FriendFeed",
+)