summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-03-27 16:45:21 +0100
committerAndreas Jaeger <aj@suse.com>2020-04-03 17:49:23 +0200
commit163c8346a3ff0499c40b69e3aa4ebad0569955ad (patch)
tree8635278746675edc3313121e1f0f802f96c630b1 /setup.py
parentb148cabdb2cc6810b09e8bfbc500d15969c0f164 (diff)
downloadironic-163c8346a3ff0499c40b69e3aa4ebad0569955ad.tar.gz
Cleanup Python 2.7 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove section from setup.cfg: Wheel is not needed for python 3 only repo - Update requirements, no need for python_version anymore Change-Id: Ib2221fc13cd53c93150e838418e7e110e087d1b3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d84432..f63cc23c5 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)