summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGabriel Hurley <gabriel@strikeawe.com>2012-02-28 23:27:46 -0800
committerGabriel Hurley <gabriel@strikeawe.com>2012-02-29 00:20:13 -0800
commit052aa55d34a8d9ee9a58969c3a20587cac9adc04 (patch)
treec6fda0d1f8ce0ce870645cf8ba5532a7245b7fc7 /setup.py
parentfca0b641a733ff3f1b3697ca04ebffb65e6c20fa (diff)
downloadhorizon-052aa55d34a8d9ee9a58969c3a20587cac9adc04.tar.gz
Unifies the project packaging into one set of modules.
There are no longer two separate projects living inside the horizon repository. There is a single project now with a single setup.py, single README, etc. The openstack-dashboard/dashboard django project is now named "openstack_dashboard" and lives as an example project in the topmost horizon directory. The "horizon/horizon" directory has been bumped up a level and now is directly on the path when the root horizon directory is on your python path. Javascript media which the horizon module directly relies upon now ships in the horizon/static dir rather than openstack-dashboard/dashboard/static. All the corresponding setup, installation, build, and env scripts have been updated accordingly. Implements blueprint unified-packaging. Change-Id: Ieed8e3c777432cd046c3e0298869a9428756ab62
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py52
1 files changed, 52 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 000000000..4f5430f38
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,52 @@
+# vim: tabstop=4 shiftwidth=4 softtabstop=4
+
+# Copyright 2012 United States Government as represented by the
+# Administrator of the National Aeronautics and Space Administration.
+# All Rights Reserved.
+#
+# Copyright 2012 Nebula, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may
+# not use this file except in compliance with the License. You may obtain
+# a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations
+# under the License.
+
+import os
+from setuptools import setup, find_packages, findall
+from horizon import version
+
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+
+setup(name="horizon",
+ version=version.canonical_version_string(),
+ url='https://github.com/openstack/horizon/',
+ license='Apache 2.0',
+ description="The OpenStack Dashboard.",
+ long_description=read('README.rst'),
+ author='Devin Carlen',
+ author_email='devin.carlen@gmail.com',
+ packages=find_packages(),
+ package_data={'horizon': [s[len('horizon/'):] for s in
+ findall('horizon/templates') \
+ + findall('horizon/dashboards/nova/templates') \
+ + findall('horizon/dashboards/syspanel/templates') \
+ + findall('horizon/dashboards/settings/templates')]},
+ install_requires=[],
+ classifiers=['Development Status :: 4 - Beta',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Internet :: WWW/HTTP']
+)