summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteve Baker <sbaker@redhat.com>2012-12-21 09:20:49 +1300
committerSteve Baker <sbaker@redhat.com>2012-12-21 09:20:49 +1300
commit1a15f6fd8dabb22cf32c41045d08c229a4962d9e (patch)
treeda4d109952f6c0ecaab69f18366e4feb2a1e3bc4 /setup.py
parent305f6753abdc9459305cc9c8d21cc17d2d39778b (diff)
downloadheat-cfntools-1a15f6fd8dabb22cf32c41045d08c229a4962d9e.tar.gz
Reorganise project to contain stand-alone heat-cfntools
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 15 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 95f7551..37c8a55 100755
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,19 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-import gettext
import os
-import subprocess
-
import setuptools
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
setuptools.setup(
- name='heat-jeos',
- version='7',
- description='The heat-jeos project provides services for creating '
- '(J)ust (E)nough (O)perating (S)ystem images',
+ name='heat-cfntools',
+ version='1.0',
+ description='Tools required to be installed on Heat '
+ 'provisioned cloud instances',
+ long_description=read('README.rst'),
license='Apache License (2.0)',
author='Heat API Developers',
author_email='discuss@heat-api.org',
@@ -37,5 +39,10 @@ setuptools.setup(
'Programming Language :: Python :: 2.6',
'Environment :: No Input/Output (Daemon)',
],
- scripts=['bin/heat-jeos'],
+ scripts=[
+ 'bin/cfn-get-metadata',
+ 'bin/cfn-hup',
+ 'bin/cfn-init',
+ 'bin/cfn-push-stats',
+ 'bin/cfn-signal'],
py_modules=[])