summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-05 08:19:29 +0200
committerAndreas Jaeger <aj@suse.com>2020-04-05 08:20:21 +0200
commit8ba16057db157b1759924ff9d85e1a08b79043b5 (patch)
treedaedad587202da193c9de7cf1eeae6946ff171f9 /setup.py
parentbf64eb26dad37f86e83d6910f474db3c619ab4dc (diff)
downloadglance_store-8ba16057db157b1759924ff9d85e1a08b79043b5.tar.gz
Cleanup py27 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo - Update classifiers - Update requirements, no need for python_version anymore Change-Id: I12ecea6b3cfcca8edd5adedac91f906d77f4ff36
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 566d844..cd35c3c 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)