summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Riedemann <mriedem@us.ibm.com>2015-05-13 06:47:32 -0700
committerMatt Riedemann <mriedem@us.ibm.com>2015-05-13 06:47:32 -0700
commit78984a8432663c74a5be65a92e9cf496c3a9f242 (patch)
tree906fa17e4572f24fb94e753f659e346c1eab11f8 /setup.py
parent56c9486800a371e853056a3badd6eb11c2f88ad9 (diff)
downloadglance_store-78984a8432663c74a5be65a92e9cf496c3a9f242.tar.gz
Sync up with global-requirements
Change Ib41b0c482edf39017f26e483cd3661ca5b540133 adds glance_store to projects.txt in the requirements repo so glance_store will start getting automatic requirement updates when global-requirements is updated. This is the preliminary sync for the master branch. Closes-Bug: #1454695 Change-Id: I687ca6ee820aad2d9a19801248ae86e7198ee556
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)