summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlvaro Silva <alvaro.silva@openbossa.org>2010-04-12 11:42:44 -0400
committerClaudio Takahasi <claudio.takahasi@openbossa.org>2010-05-07 14:36:57 -0300
commit7ac461467601ebea7e184c68408b0c52c146cb9c (patch)
tree28beefa789359fd0be3603a67abaefa4a0b2d7ab /configure.ac
parent81419cae9594d7a5706b8a92ed887d2003064e58 (diff)
downloadobexd-7ac461467601ebea7e184c68408b0c52c146cb9c.tar.gz
Add libical dependency
This library is required when PBAP dummy back-end is enabled to parse vCards. vCards read from file system needs be parsed and filtered to reply to PCE requests properly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 031a5de..473ef3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,13 @@ AC_ARG_WITH(phonebook, AC_HELP_STRING([--with-phonebook=DRIVER], [select phonebo
fi
])
+if (test "${phonebook_driver}" = "dummy"); then
+ PKG_CHECK_MODULES(LIBICAL, libical, dummy=yes,
+ AC_MSG_ERROR(libical is required))
+ AC_SUBST(LIBICAL_CFLAGS)
+ AC_SUBST(LIBICAL_LIBS)
+fi
+
if (test "${phonebook_driver}" = "ebook"); then
AC_DEFINE(NEED_THREADS, 1, [Define if threading support is required])