summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinicius Costa Gomes <vinicius.gomes@openbossa.org>2010-03-02 17:25:24 -0300
committerVinicius Costa Gomes <vinicius.gomes@openbossa.org>2010-03-02 17:25:24 -0300
commit25d14a79f6b6c8e1363926d5773dbf7d6faef30d (patch)
treeb47c91b14f8fd98425f0b700f1ef6e1196afe731 /configure.ac
parent4dd33be34dc1ffe23df02c1283fa880b84d9c165 (diff)
downloadobexd-25d14a79f6b6c8e1363926d5773dbf7d6faef30d.tar.gz
Fix passing the --with-<plugin> configure option
The commit that fixed the --without-* option broke this. There's no way to avoid "no" being passed to $withval. So we must deal with it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cca5ce9..649723f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,11 @@ AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug],
])
phonebook_driver=dummy
AC_ARG_WITH(phonebook, AC_HELP_STRING([--with-phonebook=DRIVER], [select phonebook driver]), [
- phonebook_driver=${withval}, phonebook_driver=dummy
+ if (test "${withval}" = "no"); then
+ phonebook_driver=dummy;
+ else
+ phonebook_driver=${withval};
+ fi
])
if (test "${phonebook_driver}" = "ebook"); then
@@ -128,7 +132,11 @@ AC_SUBST([PHONEBOOK_DRIVER], [phonebook-${phonebook_driver}.c])
telephony_driver=dummy
AC_ARG_WITH(telephony, AC_HELP_STRING([--with-telephony=DRIVER], [select telephony driver]), [
- telephony_driver=${withval}, telephony_driver=dummy
+ if (test "${withval}" = "no"); then
+ telephony_driver=dummy;
+ else
+ telephony_driver=${withval};
+ fi
])
AC_SUBST([TELEPHONY_DRIVER], [telephony-${telephony_driver}.c])