summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorcls%seawood.org <devnull@localhost>2005-06-02 04:21:17 +0000
committercls%seawood.org <devnull@localhost>2005-06-02 04:21:17 +0000
commit69561d06a566e704b85aff1f2d9e2ff9be98e625 (patch)
tree97657ea1f4521d4d9fc5ffb2705c0da1451abced /configure.in
parent69f47b851d1a4316ec48973735043433fd488646 (diff)
parent7c2e4fee0c0c3f3d04ba717352c247235cb997a0 (diff)
downloadnspr-hg-69561d06a566e704b85aff1f2d9e2ff9be98e625.tar.gz
Path translation fixes for msys.
Thanks to Howard Chu <hyc@symas.com> for the patches. Bug #294122 r=cls a=shaver
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b6d03db6..e26f9bfe 100644
--- a/configure.in
+++ b/configure.in
@@ -741,7 +741,10 @@ dnl ========================================================
dnl Override of system specific host options
dnl ========================================================
case "$host" in
-*-mingw*|*-cygwin*|*-msvc*|*-mks*)
+*-mingw*)
+ NSINSTALL=nsinstall
+ ;;
+*-cygwin*|*-msvc*|*-mks*)
NSINSTALL='$(CYGWIN_WRAPPER) nsinstall'
if test `echo "${PATH}" | grep -c \;` = 0; then
CYGWIN_WRAPPER='sh $(topsrcdir)/build/cygwin-wrapper'
@@ -2518,10 +2521,10 @@ fi
RELEASE_OBJDIR_NAME="${OS_CONFIG}${CPU_ARCH_TAG}${COMPILER_TAG}${IMPL_STRATEGY}${OBJDIR_TAG}.${OBJDIR_SUFFIX}"
dnl ========================================================
-dnl Use cygwin wrapper for win32 builds
+dnl Use cygwin wrapper for win32 builds, except MSYS/MinGW
dnl ========================================================
case "$target_os" in
-mingw*|cygwin*|msvc*|mks*)
+cygwin*|msvc*|mks*)
CC="\$(CYGWIN_WRAPPER) $CC"
CXX="\$(CYGWIN_WRAPPER) $CXX"
RC="\$(CYGWIN_WRAPPER) $RC"