summaryrefslogtreecommitdiff
path: root/legacy-app-handler/Makefile.am
diff options
context:
space:
mode:
authorJonathan Maw <jonathan.maw@codethink.co.uk>2012-07-06 13:51:03 +0100
committerJonathan Maw <jonathan.maw@codethink.co.uk>2012-07-10 12:14:31 +0100
commitbeac0e70767b2e4945a239bbac2cb3bcbea46faf (patch)
tree5ca4311b7b38ae9af6f07ad30904a9aca24fce4a /legacy-app-handler/Makefile.am
parentb037ff91e2d985674e6ef6f0b78deef8c6f8d91b (diff)
downloadnode-startup-controller-beac0e70767b2e4945a239bbac2cb3bcbea46faf.tar.gz
Change legacy app handler to register on the system bus
Makes the legacy app handler connect to the system bus instead of the session bus. This commit also changes bus names to consistently use LegacyAppHandler1 instead of LAHandler1. This commit does not allow communication with the legacy app handler by command-line. The following commit will provide this. This commit does not provide a way to start the legacy app handler through systemd. The following commit also provides this.
Diffstat (limited to 'legacy-app-handler/Makefile.am')
-rw-r--r--legacy-app-handler/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/legacy-app-handler/Makefile.am b/legacy-app-handler/Makefile.am
index 4f2425e..9ac1c0c 100644
--- a/legacy-app-handler/Makefile.am
+++ b/legacy-app-handler/Makefile.am
@@ -1,5 +1,10 @@
# vi:set ts=8 sw=8 noet ai nocindent:
+legacy_app_handler_confdir = /etc/dbus-1/system.d
+
+legacy_app_handler_conf_DATA = \
+ org.genivi.LegacyAppHandler1.conf
+
legacy_app_handlerdir = \
$(libdir)/legacy-app-handler-$(BOOT_MANAGER_VERSION_API)
@@ -49,7 +54,7 @@ legacy_app_handler_LDADD = \
servicedir = $(datadir)/dbus-1/services
service_in_files = \
- org.genivi.LAHandler1.service.in
+ org.genivi.LegacyAppHandler1.service.in
service_DATA = $(service_in_files:.service.in=.service)