summaryrefslogtreecommitdiff
path: root/legacy-app-handler/Makefile.am
diff options
context:
space:
mode:
authorJonathan Maw <jonathan.maw@codethink.co.uk>2012-06-27 17:46:51 +0100
committerJonathan Maw <jonathan.maw@codethink.co.uk>2012-07-05 17:17:22 +0100
commit7169b246f37985773878be1bd23f742070e7f5e3 (patch)
tree0fca570f11ef74465271c08b98f93953f531e3ec /legacy-app-handler/Makefile.am
parent85a9ee7e9b93d9dc7d16fbff3c3f35a5640efdea (diff)
downloadnode-startup-controller-7169b246f37985773878be1bd23f742070e7f5e3.tar.gz
Create a shutdown consumer object for every --register activation
On receiving a --register command line, or a call to the Register() method, the legacy app handler will create a shutdown consumer object (although it will not register it with the NSM yet). When something (e.g. the NSM) tells the shutdown consumer to shut down, it emits the signal "shutdown-requested", which the Legacy App Handler listens for. The Legacy App Handler responds to the "shutdown-requested" signal by calling the boot manager's Stop() method.
Diffstat (limited to 'legacy-app-handler/Makefile.am')
-rw-r--r--legacy-app-handler/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/legacy-app-handler/Makefile.am b/legacy-app-handler/Makefile.am
index 38c1b75..4f2425e 100644
--- a/legacy-app-handler/Makefile.am
+++ b/legacy-app-handler/Makefile.am
@@ -37,7 +37,7 @@ legacy_app_handler_LDFLAGS = \
$(PLATFORM_LDFLAGS)
legacy_app_handler_DEPENDENCIES = \
- $(top_builddir)/common/libcommon.la
+ $(top_builddir)/common/libcommon.la
legacy_app_handler_LDADD = \
$(DLT_LIBS) \