summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Maw <jonathan.maw@codethink.co.uk>2014-12-01 12:59:33 +0000
committerJonathan Maw <jonathan.maw@codethink.co.uk>2014-12-01 14:07:59 +0000
commitfba1b26575c75390be28a8a020953f030114df87 (patch)
tree876a5940faba2552b97ac67058876b5a5fc501f1 /configure.ac
parent481723d02af0d2c73187ad73b2b7bdb1dac0f1e5 (diff)
downloadnode-startup-controller-fba1b26575c75390be28a8a020953f030114df87.tar.gz
Disable the NSM dummy by default
The Node State Manager now exists, so the dummy is not required.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f05617..60e4bd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,17 @@ AC_DEFINE_UNQUOTED([PRIORITISED_LUC_TYPES],
["$with_prioritised_luc_types"],
[Prioritised LUC types])
+dnl ************************
+dnl *** Enable NSM dummy ***
+dnl ************************
+
+AC_ARG_ENABLE([nsm-dummy],
+ [AC_HELP_STRING([--enable-nsm-dummy],
+ [Enable the Node State Manager dummy application])],
+ [enable_nsm_dummy=yes],
+ [])
+AM_CONDITIONAL(ENABLE_NSM_DUMMY, test "x$enable_nsm_dummy" = "xyes")
+
AC_OUTPUT([
Makefile
node-startup-controller/busconf/Makefile