summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-06-15 16:29:09 +0100
committerJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-06-19 14:40:04 +0100
commit20c26653cf1d1b5d9713a8c7fd65a27a3124e177 (patch)
tree9742216afc087a5b4c476e5c536333f621c348cf /configure.ac
parent4724b4a524e7137ec6972615e819fe5f34fa08c0 (diff)
downloadnode-startup-controller-20c26653cf1d1b5d9713a8c7fd65a27a3124e177.tar.gz
Add --with-prioritised-luc-types=foo,bar configure option
This option results in a PRIORITISED_LUC_TYPES define in config.h. The LUCStarter can then parse that to find out in which order to start the applications in the LUC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13297c9..1188850 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,17 @@ else
AC_MSG_RESULT([no])
fi
+dnl ***************************************************
+dnl *** Configure option for prioritising LUC types ***
+dnl ***************************************************
+AC_ARG_WITH([prioritised-luc-types],
+ [AS_HELP_STRING([--with-prioritised-luc-types=LIST],
+ [Comma-separated list of LUC types to be prioritised during start-up])],
+ [with_prioritised_luc_types=$withval], [with_prioritised_luc_types=])
+AC_DEFINE_UNQUOTED([PRIORITISED_LUC_TYPES],
+ ["$with_prioritised_luc_types"],
+ [Prioritised LUC types])
+
AC_OUTPUT([
Makefile
boot-manager/Makefile