summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2020-11-30 19:54:10 +0100
committerNiels Möller <nisse@lysator.liu.se>2020-11-30 20:02:57 +0100
commit58a0301437e9beb23130423ff1063a67b6f2b43b (patch)
tree1640513150ae83d26591656ffe12d0fa0e6230ae /configure.ac
parent58c55046beda976b10ac3ce930696d172e5e5038 (diff)
downloadnettle-58a0301437e9beb23130423ff1063a67b6f2b43b.tar.gz
ppc: New assembly for chacha_core4, doing four blocks in parallel.
* chacha-crypt.c: (_nettle_chacha_crypt_4core) (_nettle_chacha_crypt32_4core): New functions. * chacha-internal.h: Add prototypes for _nettle_chacha_4core and related functions. * configure.ac (asm_nettle_optional_list): Add chacha-4core.asm. * powerpc64/fat/chacha-4core.asm: New file. * powerpc64/p7/chacha-4core.asm: New file. * fat-ppc.c (fat_init): When altivec is available, use _nettle_chacha_crypt_4core and _nettle_chacha_crypt32_4core instead of _2core variants.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6fafaa77..776a9a61 100644
--- a/configure.ac
+++ b/configure.ac
@@ -499,8 +499,9 @@ asm_replace_list="aes-encrypt-internal.asm aes-decrypt-internal.asm \
# Assembler files which generate additional object files if they are used.
asm_nettle_optional_list="gcm-hash.asm gcm-hash8.asm cpuid.asm \
aes-encrypt-internal-2.asm aes-decrypt-internal-2.asm memxor-2.asm \
- chacha-2core.asm chacha-3core.asm chacha-core-internal-2.asm salsa20-2core.asm \
- salsa20-core-internal-2.asm sha1-compress-2.asm sha256-compress-2.asm \
+ chacha-2core.asm chacha-3core.asm chacha-4core.asm chacha-core-internal-2.asm \
+ salsa20-2core.asm salsa20-core-internal-2.asm \
+ sha1-compress-2.asm sha256-compress-2.asm \
sha3-permute-2.asm sha512-compress-2.asm \
umac-nh-n-2.asm umac-nh-2.asm"
@@ -609,8 +610,10 @@ AH_VERBATIM([HAVE_NATIVE],
#undef HAVE_NATIVE_chacha_core
#undef HAVE_NATIVE_chacha_2core
#undef HAVE_NATIVE_chacha_3core
+#undef HAVE_NATIVE_chacha_4core
#undef HAVE_NATIVE_fat_chacha_2core
#undef HAVE_NATIVE_fat_chacha_3core
+#undef HAVE_NATIVE_fat_chacha_4core
#undef HAVE_NATIVE_ecc_curve25519_modp
#undef HAVE_NATIVE_ecc_curve448_modp
#undef HAVE_NATIVE_ecc_secp192r1_modp