summaryrefslogtreecommitdiff
path: root/Ada95/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Ada95/configure.in')
-rw-r--r--Ada95/configure.in133
1 files changed, 36 insertions, 97 deletions
diff --git a/Ada95/configure.in b/Ada95/configure.in
index 2b89fd4..83d9ce4 100644
--- a/Ada95/configure.in
+++ b/Ada95/configure.in
@@ -1,5 +1,5 @@
dnl***************************************************************************
-dnl Copyright (c) 2010,2011 Free Software Foundation, Inc. *
+dnl Copyright (c) 2010-2013,2014 Free Software Foundation, Inc. *
dnl *
dnl Permission is hereby granted, free of charge, to any person obtaining a *
dnl copy of this software and associated documentation files (the *
@@ -28,24 +28,20 @@ dnl***************************************************************************
dnl
dnl Author: Thomas E. Dickey
dnl
-dnl $Id: configure.in,v 1.30 2011/03/31 22:49:22 tom Exp $
+dnl $Id: configure.in,v 1.56 2014/08/02 20:29:22 tom Exp $
dnl Process this file with autoconf to produce a configure script.
dnl
dnl See http://invisible-island.net/autoconf/ for additional information.
dnl
dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.13.20020210)
-AC_REVISION($Revision: 1.30 $)
+AC_PREREQ(2.52.20030208)
+AC_REVISION($Revision: 1.56 $)
AC_INIT(gen/gen.c)
AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
CF_TOP_BUILDDIR
-CF_CHECK_CACHE([AC_CANONICAL_SYSTEM])
-AC_ARG_WITH(system-type,
-[ --with-system-type=XXX test: override derived host system-type],
-[AC_MSG_WARN(overriding system type to $withval)
- cf_cv_system_name=$withval])
+CF_WITH_SYSTYPE
### Save the given $CFLAGS to allow user-override.
cf_user_CFLAGS="$CFLAGS"
@@ -54,15 +50,10 @@ cf_user_CFLAGS="$CFLAGS"
CF_CFG_DEFAULTS
### Checks for programs.
-AC_PROG_CC
-CF_GCC_VERSION
-
+CF_PROG_CC(gnatgcc gcc cc)
AC_PROG_CPP
AC_PROG_GCC_TRADITIONAL
CF_PROG_CC_C_O(CC)
-AC_ISC_POSIX
-CF_ANSI_CC_REQD
-CF_PROG_EXT
AC_ARG_PROGRAM
@@ -75,28 +66,7 @@ AC_SYS_LONG_FILE_NAMES
# if we find pkg-config, check if we should install the ".pc" files.
CF_PKG_CONFIG
-
-if test "$PKG_CONFIG" != none ; then
- AC_MSG_CHECKING(if we should install .pc files for $PKG_CONFIG)
-
- # Leave this as something that can be overridden in the environment.
- if test -z "$PKG_CONFIG_LIBDIR" ; then
- PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG" | sed -e 's,/[[^/]]*/[[^/]]*$,,'`/lib/pkgconfig
- fi
- PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG_LIBDIR" | sed -e 's/^://' -e 's/:.*//'`
- if test -n "$PKG_CONFIG_LIBDIR" && test -d "$PKG_CONFIG_LIBDIR" ; then
- AC_ARG_ENABLE(pc-files,
- [ --enable-pc-files generate and install .pc files for pkg-config],
- [enable_pc_files=$enableval],
- [enable_pc_files=no])
- AC_MSG_RESULT($enable_pc_files)
- else
- AC_MSG_RESULT(no)
- AC_MSG_WARN(did not find library $PKG_CONFIG_LIBDIR)
- enable_pc_files=no
- fi
-fi
-AC_SUBST(PKG_CONFIG_LIBDIR)
+CF_WITH_PKG_CONFIG_LIBDIR
AC_MSG_CHECKING(if you want to build test-programs)
AC_ARG_WITH(tests,
@@ -130,6 +100,7 @@ AC_CHECK_TOOL(RANLIB, ranlib, ':')
AC_CHECK_TOOL(LD, ld, ld)
AC_CHECK_TOOL(AR, ar, ar)
CF_AR_FLAGS
+CF_PATHSEP
dnl Special option for use by system-builders: the install-prefix is used to
dnl adjust the location into which the actual install is done, so that an
@@ -186,9 +157,7 @@ AC_SUBST(DFT_UPR_MODEL)dnl the default model ("NORMAL")
CF_NCURSES_ADDON
-CF_LIB_PREFIX(cf_prefix)
-LIB_PREFIX=$cf_prefix
-AC_SUBST(LIB_PREFIX)
+CF_WITH_LIB_PREFIX(cf_prefix)
LIB_SUFFIX=
AC_SUBST(LIB_SUFFIX)
@@ -235,8 +204,6 @@ fi
###############################################################################
CF_HELP_MESSAGE(Fine-Tuning Your Configuration:)
-CF_PATHSEP
-
### use option --enable-broken-linker to force on use of broken-linker support
AC_MSG_CHECKING(if you want broken-linker support code)
AC_ARG_ENABLE(broken_linker,
@@ -272,7 +239,7 @@ AC_ARG_WITH(rcs-ids,
[with_rcs_ids=$withval],
[with_rcs_ids=no])
AC_MSG_RESULT($with_rcs_ids)
-test "$with_rcs_ids" = yes && AC_DEFINE(USE_RCS_IDS)
+test "$with_rcs_ids" = yes && AC_DEFINE(USE_RCS_IDS,1,[Define to 1 if RCS identifiers should be compiled-in)])
###############################################################################
CF_HELP_MESSAGE(Extensions:)
@@ -286,8 +253,8 @@ AC_ARG_ENABLE(ext-funcs,
AC_MSG_RESULT($with_ext_funcs)
if test "$with_ext_funcs" = yes ; then
NCURSES_EXT_FUNCS=1
- AC_DEFINE(HAVE_USE_DEFAULT_COLORS)
- AC_DEFINE(NCURSES_EXT_FUNCS)
+ AC_DEFINE(HAVE_USE_DEFAULT_COLORS,1,[Define to 1 if we have use_default_colors function])
+ AC_DEFINE(NCURSES_EXT_FUNCS,1,[Define to 1 if we have ncurses extended functions])
else
NCURSES_EXT_FUNCS=0
fi
@@ -337,12 +304,12 @@ else
fi
if test $cf_cv_weak_symbols = yes ; then
- AC_DEFINE(USE_WEAK_SYMBOLS)
+ AC_DEFINE(USE_WEAK_SYMBOLS,1,[Define to 1 to enable weak-symbols for pthreads])
fi
PTHREAD=
if test "$with_pthread" = "yes" ; then
- AC_DEFINE(USE_PTHREADS)
+ AC_DEFINE(USE_PTHREADS,1,[Define to 1 to use the pthreads library])
enable_reentrant=yes
if test $cf_cv_weak_symbols = yes ; then
PTHREAD=-lpthread
@@ -370,7 +337,7 @@ if test "$with_reentrant" = yes ; then
elif test "$assume_reentrant" = no ; then
LIB_SUFFIX="t${LIB_SUFFIX}"
fi
- AC_DEFINE(USE_REENTRANT)
+ AC_DEFINE(USE_REENTRANT,1,[Define to 1 to compile with experimental reentrant code])
else
cf_cv_enable_reentrant=0
fi
@@ -388,24 +355,13 @@ else
NCURSES_WRAP_PREFIX=_nc_
fi
AC_SUBST(NCURSES_WRAP_PREFIX)
-AC_DEFINE_UNQUOTED(NCURSES_WRAP_PREFIX,"$NCURSES_WRAP_PREFIX")
+AC_DEFINE_UNQUOTED(NCURSES_WRAP_PREFIX,"$NCURSES_WRAP_PREFIX",[Define to override _nc_ ncurses internal prefix])
###############################################################################
CF_HELP_MESSAGE(Testing/development Options:)
### use option --disable-echo to suppress full display compiling commands
-AC_MSG_CHECKING(if you want to display full commands during build)
-AC_ARG_ENABLE(echo,
- [ --enable-echo build: display "compiling" commands (default)],
- [with_echo=$enableval],
- [with_echo=yes])
-if test "$with_echo" = yes; then
- ECHO_LINK=
-else
- ECHO_LINK='@ echo linking $@ ... ;'
-fi
-AC_MSG_RESULT($with_echo)
-AC_SUBST(ECHO_LINK)
+CF_DISABLE_ECHO
### use option --enable-warnings to turn on all gcc warnings
AC_MSG_CHECKING(if you want to see compiler warnings)
@@ -416,7 +372,7 @@ AC_MSG_RESULT($with_warnings)
if test "x$with_warnings" = "xyes"; then
CF_ADD_ADAFLAGS(-gnatg)
- CF_GCC_WARNINGS(Wdeclaration-after-statement Wextra Wno-unknown-pragmas Wswitch-enum)
+ CF_GCC_WARNINGS(Wno-unknown-pragmas Wswitch-enum)
fi
CF_GCC_ATTRIBUTES
@@ -431,7 +387,6 @@ if test -n "$GCC"
then
if test "$with_assertions" = no
then
- AC_DEFINE(NDEBUG)
CPPFLAGS="$CPPFLAGS -DNDEBUG"
else
CF_ADD_ADAFLAGS(-gnata)
@@ -439,17 +394,17 @@ then
fi
### use option --disable-leaks to suppress "permanent" leaks, for testing
-AC_DEFINE(HAVE_NC_ALLOC_H)
+AC_DEFINE(HAVE_NC_ALLOC_H,1,[Define to 1 if we have nc_alloc.h header])
### use option --enable-expanded to generate certain macros as functions
AC_ARG_ENABLE(expanded,
[ --enable-expanded test: generate functions for certain macros],
- [test "$enableval" = yes && AC_DEFINE(NCURSES_EXPANDED)])
+ [test "$enableval" = yes && AC_DEFINE(NCURSES_EXPANDED,1,[Define to 1 if ncurses macros should be expanded as functions])])
### use option --disable-macros to suppress macros in favor of functions
AC_ARG_ENABLE(macros,
[ --disable-macros test: use functions rather than macros],
- [test "$enableval" = no && AC_DEFINE(NCURSES_NOMACROS)])
+ [test "$enableval" = no && AC_DEFINE(NCURSES_NOMACROS,1,[Define to 1 if ncurses macros should be expanded as functions])])
# Normally we only add trace() to the debug-library. Allow this to be
# extended to all models of the ncurses library:
@@ -476,6 +431,8 @@ fi
AC_SUBST(ADA_TRACE)
+CF_DISABLE_GNAT_PROJECTS
+
### Checks for libraries.
case $cf_cv_system_name in #(vi
*mingw32*) #(vi
@@ -485,7 +442,7 @@ AC_CHECK_FUNC(gettimeofday,
AC_DEFINE(HAVE_GETTIMEOFDAY),[
AC_CHECK_LIB(bsd, gettimeofday,
- AC_DEFINE(HAVE_GETTIMEOFDAY)
+ AC_DEFINE(HAVE_GETTIMEOFDAY,1,[Define to 1 if we have gettimeofday])
LIBS="$LIBS -lbsd")])dnl CLIX: bzero, select, gettimeofday
;;
esac
@@ -505,8 +462,6 @@ CF_LINK_DATAONLY
### Checks for library functions.
CF_MKSTEMP
-AC_TYPE_SIGNAL
-
dnl We'll do our own -g libraries, unless the user's overridden via $CFLAGS
if test -z "$cf_user_CFLAGS" && test "$with_no_leaks" = no ; then
CF_STRIP_G_OPT(CFLAGS)
@@ -514,28 +469,18 @@ if test -z "$cf_user_CFLAGS" && test "$with_no_leaks" = no ; then
fi
CF_HELP_MESSAGE(Ada95 Binding Options:)
-
+cf_with_ada=yes
dnl Check for availability of GNU Ada Translator (GNAT).
dnl At the moment we support no other Ada95 compiler.
if test "$cf_with_ada" != "no" ; then
CF_PROG_GNAT
if test "$cf_cv_prog_gnat_correct" = yes; then
+ CF_FIXUP_ADAFLAGS
- # make ADAFLAGS consistent with CFLAGS
- case "$CFLAGS" in
- *-g*)
- CF_ADD_ADAFLAGS(-g)
- ;;
- esac
- case "$CFLAGS" in
- *-O*)
- CF_ADD_ADAFLAGS(-O3)
- ;;
- esac
+ CF_GNATPREP_OPT_T
CF_GNAT_GENERICS
CF_GNAT_SIGINT
- CF_GNAT_PRAGMA_UNREF
CF_GNAT_PROJECTS
CF_WITH_ADA_COMPILER
@@ -556,8 +501,10 @@ fi
################################################################################
# not needed
-TINFO_ARGS2=
-AC_SUBST(TINFO_ARGS2)
+TINFO_LDFLAGS2=
+AC_SUBST(TINFO_LDFLAGS2)
+TINFO_LIBS=
+AC_SUBST(TINFO_LIBS)
### Construct the list of include-directories to be generated
CF_INCLUDE_DIRS
@@ -586,6 +533,9 @@ if test "$DFT_LWR_MODEL" = shared ; then
cygwin*)
# "lib" files have ".dll.a" suffix, "cyg" files have ".dll"
;;
+ msys*)
+ # "lib" files have ".dll.a" suffix, "msys-" files have ".dll"
+ ;;
esac
fi
@@ -594,24 +544,13 @@ fi
SUB_MAKEFILES="gen/adacurses${DFT_ARG_SUFFIX}-config:gen/adacurses-config.in"
-AC_DEFINE_UNQUOTED(NCURSES_PATHSEP,'$PATH_SEPARATOR')
+AC_DEFINE_UNQUOTED(NCURSES_PATHSEP,'$PATH_SEPARATOR',[Define to override ':' as the library path-separator])
### Now that we're done running tests, add the compiler-warnings, if any
CF_ADD_CFLAGS($EXTRA_CFLAGS)
################################################################################
-if test x"$enable_pc_files" = xyes ; then \
-SUB_MAKEFILES="$SUB_MAKEFILES misc/gen-pkgconfig:misc/gen-pkgconfig.in"
-MAKE_PC_FILES=
-else
-MAKE_PC_FILES="#"
-fi
-AC_SUBST(MAKE_PC_FILES)
-AC_SUBST(cross_compiling)
-
-################################################################################
-
TEST_ARG2=
AC_SUBST(TEST_ARG2)
@@ -656,8 +595,8 @@ fi
AWK="$AWK"
DFT_ARG_SUFFIX="$DFT_ARG_SUFFIX"
DFT_LWR_MODEL="$DFT_LWR_MODEL"
-ECHO_LINK="$ECHO_LINK"
LIB_NAME="$LIB_NAME"
+LIB_PREFIX="$LIB_PREFIX"
LIB_SUFFIX="$LIB_SUFFIX"
LN_S="$LN_S"
NCURSES_MAJOR="$NCURSES_MAJOR"