summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjandegr <jandegr@users.noreply.github.com>2019-09-26 21:43:50 +0200
committerPierre GRANDIN <pgrandin@users.noreply.github.com>2019-09-26 13:43:50 -0600
commitd18dec5ec22551ea9feeb6aedf5c226a6f998fe6 (patch)
tree6b514f5bfb063701efbb4f15f8c12ad3bd75c1eb /CMakeLists.txt
parentf304cfc699a73f9c0677d5d3315cd7e3d5daea30 (diff)
downloadnavit-d18dec5ec22551ea9feeb6aedf5c226a6f998fe6.tar.gz
Fix:android:64 bit and cleanup2 (#877)
https://github.com/navit-gps/navit/pull/877
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4890afa04..4d001b99b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,8 +16,11 @@ endif(NOT DISABLE_CXX)
set(NAVIT_VERSION_MAJOR "0")
set(NAVIT_VERSION_MINOR "5")
set(NAVIT_VERSION_PATCH "3")
-set(PACKAGE_VERSION "${NAVIT_VERSION_MAJOR}.${NAVIT_VERSION_MINOR}.${NAVIT_VERSION_PATCH}")
-
+if(ANDROID)
+ set(PACKAGE_VERSION "${NAVIT_VERSION_MAJOR}.${NAVIT_VERSION_MINOR}.${NAVIT_VERSION_PATCH}.${ANDROID_ABI}")
+else(ANDROID)
+ set(PACKAGE_VERSION "${NAVIT_VERSION_MAJOR}.${NAVIT_VERSION_MINOR}.${NAVIT_VERSION_PATCH}")
+endif(ANDROID)
set(PACKAGE_NAME "navit-git")
set(PACKAGE "navit" CACHE STRING "Navit package name")
set(PACKAGE_STRING "${PACKAGE} ${PACKAGE_VERSION}")
@@ -192,6 +195,8 @@ if(PKG_CONFIG_FOUND)
if(IMLIB2_FOUND)
set(HAVE_IMLIB2 1)
endif(IMLIB2_FOUND)
+else(PKG_CONFIG_FOUND)
+ set_with_reason(support/glib "Glib not found" TRUE ${INTL_LIBS})
endif(PKG_CONFIG_FOUND)
#find_package(Iconv)