summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormvglasow <michael -at- vonglasow.com>2021-02-28 15:04:37 +0200
committerjkoan <jkoan@users.noreply.github.com>2021-02-28 17:37:47 +0100
commitcd1f4e5584d1080d1e125da7d83ddf99e7579f81 (patch)
tree25c42b891a661efcfc48cd1f960a0a3bb014c194 /CMakeLists.txt
parent2146fcd9c9ce1560b725e481dc8b808dd425b1d2 (diff)
downloadnavit-cd1f4e5584d1080d1e125da7d83ddf99e7579f81.tar.gz
Fix:build:Use NDK libraries when building for Android
Signed-off-by: mvglasow <michael -at- vonglasow.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a9bbe5d0..58a517fe8 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -159,6 +159,12 @@ INCLUDE (CheckLibraryExists)
INCLUDE (CheckFunctionExists)
INCLUDE (CheckSymbolExists)
+if(ANDROID)
+ set(ENV{PKG_CONFIG_DIR} "")
+ set(ENV{PKG_CONFIG_LIBDIR} "${CMAKE_SYSROOT}/usr/lib/pkgconfig:${CMAKE_SYSROOT}/usr/share/pkgconfig")
+ set(ENV{PKG_CONFIG_SYSROOT_DIR} ${CMAKE_SYSROOT})
+endif(ANDROID)
+
################################
# pkg-config based detection #
################################