summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormetalstrolch <stefan.wildemann@metalstrolche.de>2021-12-17 11:10:18 +0100
committerjkoan <jkoan@users.noreply.github.com>2021-12-17 13:19:36 +0100
commit6f52bb5aa557ef025859b636f8f6f971e1119d67 (patch)
treede8c1f62e2aa8c8ee9ce466855049e4cca1bf44f /CMakeLists.txt
parented26d58ddcf7d48352cdd9f673f3e9096df0c905 (diff)
downloadnavit-6f52bb5aa557ef025859b636f8f6f971e1119d67.tar.gz
Fix:graphics_qt5: allow building without qml again
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 947ee1410..3f6e98403 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -386,9 +386,11 @@ if (Qt5Widgets_FOUND OR Qt5Quick_FOUND)
set_with_reason(USE_QML "Qt5Quick found" TRUE)
if(USE_QML)
set(Qt5_ADDITIONAL_LIBRARIES ${Qt5_ADDITIONAL_LIBRARIES} ${Qt5Quick_LIBRARIES})
+ set_with_reason(gui/qt5_qml "Qt5 found" TRUE
+ ${Qt5Quick_LIBRARIES})
+ else()
+ set_with_reason(gui/qt5_qml "feature USE_QML disabled for graphics/qt5" FALSE)
endif()
- set_with_reason(gui/qt5_qml "Qt5 found" TRUE
- ${Qt5Quick_LIBRARIES})
endif()
set_with_reason(graphics/qt5 "Qt5 found" TRUE