summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjandegr <jandegr@users.noreply.github.com>2018-04-21 10:48:10 +0200
committerGitHub <noreply@github.com>2018-04-21 10:48:10 +0200
commit627d699aa84ad67b92b516fd294ac941e5db6fc5 (patch)
treeffb9c8683d5c746706dd9f157be45147f29bf86e /CMakeLists.txt
parent9d9a73e3b9ff43bc7c314520bf9b749282e49b7d (diff)
downloadnavit-627d699aa84ad67b92b516fd294ac941e5db6fc5.tar.gz
Refactoring:Android:cleanup (#458)
* Update Navit.java * Update Navit.java * Update CMakeLists.txt * Update CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763f75bed..f4ce4cc97 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -698,6 +698,8 @@ if(ANDROID)
set(XSLTS "android;${XSLTS}" CACHE STRING "define a semicolon seperated list of XSLTs to process")
list(APPEND NAVIT_LIBS log)
set(HAVE_API_ANDROID 1)
+ set_with_reason(speech/cmdline "Android detected" FALSE)
+ set_with_reason(graphics/null "Android detected" FALSE)
set_with_reason(graphics/android "Android detected, NDK:${ANDROID_NDK_API_VERSION}, API:${ANDROID_API_VERSION}" TRUE)
set_with_reason(speech/android "Android detected, NDK:${ANDROID_NDK_API_VERSION}, API:${ANDROID_API_VERSION}" TRUE)
set_with_reason(vehicle/android "Android detected, NDK:${ANDROID_NDK_API_VERSION}, API:${ANDROID_API_VERSION}" TRUE)