summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLionel AINS <lains@users.noreply.github.com>2019-08-20 18:51:08 +0200
committerLionel AINS <lains@users.noreply.github.com>2019-08-20 18:59:22 +0200
commit5916b0654eef003f61ad64c54c69b69590f9ddb4 (patch)
tree0c347210ec20720300dcbb6fd33bc805d6da323d /CMakeLists.txt
parent7ecccd48c20bd6abe13cdb24de1e029ada76cbbe (diff)
downloadnavit-5916b0654eef003f61ad64c54c69b69590f9ddb4.tar.gz
Reverting part of e7a70e9dc04b94b47fb7786aab4edfd25132c70f (PR #833) that was not needed
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt52
1 files changed, 23 insertions, 29 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ce8d4b41..4890afa04 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,35 +154,31 @@ INCLUDE (CheckSymbolExists)
find_package(PkgConfig)
if(PKG_CONFIG_FOUND)
- if (NOT ANDROID)
- pkg_check_modules ( GMODULE gmodule-2.0 )
- if (GMODULE_FOUND)
- set(HAVE_GMODULE 1)
- include_directories(${GMODULE_INCLUDE_DIRS})
- list(APPEND NAVIT_LIBS ${GMODULE_LIBRARIES})
- endif(GMODULE_FOUND)
-
- pkg_check_modules (GLIB2 glib-2.0>=2.10)
- if (GLIB2_FOUND)
- set(HAVE_GLIB 1)
- include_directories(${GLIB2_INCLUDE_DIRS})
- list(APPEND NAVIT_LIBS ${GLIB2_LIBRARIES})
- else(GLIB2_FOUND)
- set_with_reason(support/glib "Glib not found" TRUE ${INTL_LIBS})
- endif(GLIB2_FOUND)
- endif(NOT ANDROID)
+ pkg_check_modules ( GMODULE gmodule-2.0 )
+ if (GMODULE_FOUND)
+ set(HAVE_GMODULE 1)
+ include_directories(${GMODULE_INCLUDE_DIRS})
+ list(APPEND NAVIT_LIBS ${GMODULE_LIBRARIES})
+ endif(GMODULE_FOUND)
+
+ pkg_check_modules (GLIB2 glib-2.0>=2.10)
+ if (GLIB2_FOUND)
+ set(HAVE_GLIB 1)
+ include_directories(${GLIB2_INCLUDE_DIRS})
+ list(APPEND NAVIT_LIBS ${GLIB2_LIBRARIES})
+ else(GLIB2_FOUND)
+ set_with_reason(support/glib "Glib not found" TRUE ${INTL_LIBS})
+ endif(GLIB2_FOUND)
pkg_check_modules(FONTCONFIG "fontconfig >= 2.2.0")
- if (NOT ANDROID)
- pkg_check_modules(DBUS "dbus-1 >= 1.4")
- pkg_check_modules(DBUSGLIB dbus-glib-1)
- if(DBUSGLIB_FOUND)
- include_directories(${DBUSGLIB_INCLUDE_DIRS})
- set_with_reason(binding/dbus "dbus-glib-1 found" TRUE ${DBUSGLIB_LIBRARIES})
- set_with_reason(speech/dbus "dbus-glib-1 found" TRUE ${DBUSGLIB_LIBRARIES})
- set_with_reason(vehicle/gpsd_dbus "dbus-glib-1 found" TRUE ${DBUSGLIB_LIBRARIES})
- endif(DBUSGLIB_FOUND)
- endif(NOT ANDROID)
+ pkg_check_modules(DBUS "dbus-1 >= 1.4")
+ pkg_check_modules(DBUSGLIB dbus-glib-1)
+ if(DBUSGLIB_FOUND)
+ include_directories(${DBUSGLIB_INCLUDE_DIRS})
+ set_with_reason(binding/dbus "dbus-glib-1 found" TRUE ${DBUSGLIB_LIBRARIES})
+ set_with_reason(speech/dbus "dbus-glib-1 found" TRUE ${DBUSGLIB_LIBRARIES})
+ set_with_reason(vehicle/gpsd_dbus "dbus-glib-1 found" TRUE ${DBUSGLIB_LIBRARIES})
+ endif()
pkg_check_modules(LIBLOCATION liblocation)
pkg_check_modules(LIBOSSO libosso)
@@ -744,8 +740,6 @@ if(ANDROID)
set_with_reason(graphics/null "Android detected" FALSE)
set_with_reason(graphics/android "Android detected" TRUE)
set_with_reason(speech/android "Android detected" TRUE)
- set_with_reason(support/ezxml "Android detected" TRUE)
- set_with_reason(support/glib "Android detected" TRUE)
set_with_reason(traffic/traff_android "Android detected" TRUE)
set_with_reason(vehicle/android "Android detected" TRUE)
set_with_reason(vehicle/file "Android detected" FALSE)