summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWildemann Stefan <stefan.wildemann@corpuls.com>2019-06-18 10:46:36 +0200
committerjkoan <jkoan@users.noreply.github.com>2019-06-18 11:13:30 +0200
commit3974cb7e4821b4e131cd677fd609433a05c453b3 (patch)
tree21235ac4c48cbc9c8f1b5f9e6f6c4b9096d0c54d /CMakeLists.txt
parent1bd73ecab8f458950aebf0c07ba7de0c4e15de81 (diff)
downloadnavit-3974cb7e4821b4e131cd677fd609433a05c453b3.tar.gz
Disable maptool if protobuf-c not found
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e6d4c683..a03cdc835 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -687,6 +687,13 @@ if(CMAKE_SIZEOF_VOID_P LESS 8)
set_with_reason(BUILD_MAPTOOL "maptool works only on 64 bit architectures" FALSE)
endif()
+if(BUILD_MAPTOOL)
+ find_package(Protobuf-c REQUIRED)
+ if(NOT PROTOBUF_C_FOUND)
+ set_with_reason(BUILD_MAPTOOL "PROTOBUF-C not found" FALSE)
+ endif()
+endif()
+
set(LOCALEDIR "${LOCALE_DIR}")
find_program(BZCAT NAMES bzcat)