summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjkoan <jkoan@users.noreply.github.com>2020-12-19 20:28:08 +0100
committerGitHub <noreply@github.com>2020-12-19 20:28:08 +0100
commit38a057375c6842caf7b84715ac0010eacbeb9a0c (patch)
treebe7ba25c2473e87886c1cd77e982be0c4810084e /CMakeLists.txt
parent3ab540c7ea34acec169e4a6ea43429edfaf41ef3 (diff)
downloadnavit-38a057375c6842caf7b84715ac0010eacbeb9a0c.tar.gz
add:graphics:svg_debug:Add svg_debugging plugin (#1061)
* graphics:svg_debug:Add initial version of svg_debug Some TODOs still remaining, but its working good so far * fiexed:svg_debug:Fixed memory leeks on exit of plugin * fix:graphics:Some final touches for svg_debug * fix:graphics:svg_debug:Reformat to match navit style * fix:graphics:svg_debug:Reformat again to match navit style (Eclipse brakes things... now astyle) * fix:grpahics:svg_debug:Fix C99 for-loop
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcf82f978..305229c30 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,7 @@ add_module(graphics/sdl "Required library not found" FALSE)
add_module(graphics/egl "Required library not found" FALSE)
add_module(graphics/qt_qpainter "Qt libraries not found" FALSE)
add_module(graphics/qt5 "Qt5 libraries not found" FALSE)
+add_module(graphics/svg_debug "native Glib not found" FALSE)
add_module(gui/qml "Qt Declarative not found" FALSE)
add_module(gui/qt5_qml "Qt5 Declarative not found" FALSE)
add_module(gui/gtk "GTK libs not found" FALSE)
@@ -325,7 +326,10 @@ if (NOT HAVE_WORDEXP)
endif()
if (NOT GLIB2_FOUND)
set_with_reason(support/ezxml "Glib not found" TRUE)
-endif()
+else(NOT GLIB2_FOUND)
+ set_with_reason(graphics/svg_debug "Glib found" TRUE)
+endif(NOT GLIB2_FOUND)
+
if(FREETYPE_FOUND)
pkg_check_modules(FRIBIDI fribidi)