summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjkoan <jkoan@users.noreply.github.com>2020-01-18 18:41:57 +0100
committerGitHub <noreply@github.com>2020-01-18 18:41:57 +0100
commit3882bc6e6af57b89e4783cc8a7e08a0539d0ece8 (patch)
tree77f69a434449c358cea44810f800a004e8227f00 /CMakeLists.txt
parent55c1900326506f948f85416518e273906b6fe391 (diff)
downloadnavit-3882bc6e6af57b89e4783cc8a7e08a0539d0ece8.tar.gz
change:build_android:Remove dependency of ant. Not needed anymore (#956)
Co-authored-by: Joseph Herlant <aerostitch@users.noreply.github.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d001b99b..a68c89747 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -725,15 +725,6 @@ if(ANDROID)
message(STATUS "Using generator " ${CMAKE_GENERATOR})
if (NOT ${CMAKE_GENERATOR} STREQUAL Ninja)
find_program(ANDROID_LOCATION NAMES android android.bat)
- find_program(ANT_LOCATION NAMES ant)
- if (NOT ANT_LOCATION)
- message_error("Could not find ant. Please install ant and add it to the search path.")
- else()
- execute_process(COMMAND ${ANT_LOCATION} WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/cmake RESULT_VARIABLE ANT_VERSION_OK OUTPUT_QUIET ERROR_QUIET)
- if(ANT_VERSION_OK GREATER 0)
- message(WARNING "Old ant version detected. If you need crash reporter, update to at least ant 1.8")
- endif()
- endif()
if (NOT ANDROID_LOCATION)
message_error( "Could not find 'Android SDK and AVD Manager'. Please install the android sdk and add the <android-sdk>/tools directory to the search path.")
endif()