summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..f0b21c0
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,30 @@
+localedir = $(datadir)/locale
+INCLUDES = -DLOCALEDIR=\"$(localedir)\" -DSYSCONFDIR=\"$(sysconfdir)\"
+
+ACLOCAL_AMFLAGS = -I m4
+
+bin_PROGRAMS = nano
+nano_SOURCES = browser.c \
+ chars.c \
+ color.c \
+ cut.c \
+ files.c \
+ global.c \
+ help.c \
+ move.c \
+ nano.c \
+ nano.h \
+ prompt.c \
+ proto.h \
+ rcfile.c \
+ search.c \
+ text.c \
+ utils.c \
+ winio.c
+
+nano_LDADD = @GLIB_LIBS@ @LIBINTL@
+
+install-exec-hook:
+ cd $(DESTDIR)$(bindir) && rm -f rnano && $(LN_S) nano rnano
+uninstall-hook:
+ cd $(DESTDIR)$(bindir) && rm -f rnano