summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEvan Broder <ebroder@mokafive.com>2012-02-29 14:52:27 -0800
committerJasper St. Pierre <jstpierre@mecheye.net>2012-05-02 14:13:48 -0400
commit4148a5cc6a6c52072bccc3a0af9dc8f07f957f75 (patch)
treeded153d599994691911a94b45a6258dc98f4bfa1 /src/Makefile.am
parent8a6a568aca9cc8fe4430d6a9b424a7fc005feaaf (diff)
downloadmutter-4148a5cc6a6c52072bccc3a0af9dc8f07f957f75.tar.gz
Fix introspection gir metadata
The EXPORT_PACKAGES variable to the GIR makefile should be the packages needed to use this gir. It's also unnecessary to set PACKAGES (which is just used for CFLAGS at scan-time) since CFLAGS is already pulls in all necessary CFLAGS. https://bugzilla.gnome.org/show_bug.cgi?id=671092
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5d5dcb9d1..d5b398c08 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -222,7 +222,7 @@ INTROSPECTION_GIRS = Meta-$(api_version).gir
Meta-$(api_version).gir: libmutter.la
@META_GIR@_INCLUDES = GObject-2.0 GDesktopEnums-3.0 Gdk-3.0 Gtk-3.0 Clutter-1.0 xlib-2.0 xfixes-4.0
-@META_GIR@_PACKAGES = clutter-1.0 gtk+-3.0
+@META_GIR@_EXPORT_PACKAGES = libmutter
@META_GIR@_CFLAGS = $(INCLUDES)
@META_GIR@_LIBS = libmutter.la
@META_GIR@_FILES = \