summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorFlorian Müllner <fmuellner@gnome.org>2010-06-19 18:39:48 +0200
committerFlorian Müllner <fmuellner@gnome.org>2010-07-02 04:36:27 +0200
commit01447d94d13a343aa72b358a72f57ff8b2cb9178 (patch)
treefc053566634040eb747ada2f3fff41578dce1ad2 /src/Makefile.am
parente267a633307a5c040b77f75e9cde7b5a2db0bd8a (diff)
downloadmutter-01447d94d13a343aa72b358a72f57ff8b2cb9178.tar.gz
Allow building with Gtk+-3.0
Add a configure switch to select the Gtk+ version to build with. The default is to build against Gtk+-2.0 >= 2.18. https://bugzilla.gnome.org/show_bug.cgi?id=622303
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1753d4a36..f9a29c9d2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -211,11 +211,11 @@ Meta-$(api_version).gir: $(G_IR_SCANNER) mutter $(libmutterinclude_HEADERS) $(mu
--namespace=Meta \
--nsversion=$(api_version) \
--include=GObject-2.0 \
- --include=Gdk-2.0 \
- --include=Gtk-2.0 \
+ --include=Gdk-@GTK_API_VERSION@ \
+ --include=Gtk-@GTK_API_VERSION@ \
--include=Clutter-1.0 \
--pkg=clutter-1.0 \
- --pkg=gtk+-2.0 \
+ --pkg=gtk+-@GTK_API_VERSION@ \
--include=xlib-2.0 \
--include=xfixes-4.0 \
--program=$$pwd/mutter \