summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJasper St. Pierre <jstpierre@mecheye.net>2014-10-15 10:35:53 -0700
committerJasper St. Pierre <jstpierre@mecheye.net>2014-10-15 10:40:28 -0700
commitd88c8d9ced0e0b1cb570007e7857928e8d1046b6 (patch)
tree07fa83368efe758d8ddbeea52b0113413e97e8a6 /configure.ac
parent60ab11ecbfa0d30f7a750af48782b48c686375f1 (diff)
downloadmutter-d88c8d9ced0e0b1cb570007e7857928e8d1046b6.tar.gz
Make gbm optional
Now it's only required by the native backend. The cursor code is getting quite messy, but it was already considerable messy to start with.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c1a48ce91..f238972a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,7 +201,7 @@ AC_SUBST(XWAYLAND_PATH)
PKG_CHECK_MODULES(MUTTER, $MUTTER_PC_MODULES)
-PKG_CHECK_MODULES(MUTTER_NATIVE_BACKEND, [clutter-egl-1.0 libdrm libsystemd libinput gudev-1.0], [have_native_backend=yes], [have_native_backend=no])
+PKG_CHECK_MODULES(MUTTER_NATIVE_BACKEND, [clutter-egl-1.0 libdrm libsystemd libinput gudev-1.0 gbm >= 10.3], [have_native_backend=yes], [have_native_backend=no])
if test $have_native_backend = yes; then
AC_DEFINE([HAVE_NATIVE_BACKEND],[1],[Define if you want to enable the native (KMS) backend based on systemd])
fi