summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJasper St. Pierre <jstpierre@mecheye.net>2014-08-26 16:38:20 -0400
committerJasper St. Pierre <jstpierre@mecheye.net>2014-08-26 16:58:13 -0400
commit3d37b5d69681562c446925e3cbcea4ffe281b1fb (patch)
tree29102346a290e5c321f7216e3bf0e7ffe5bdf431 /configure.ac
parent3a8bad1e6f0622127e2377ac6d849f9b554b6f88 (diff)
downloadmutter-3d37b5d69681562c446925e3cbcea4ffe281b1fb.tar.gz
configure: Conditionalize WAYLAND_SCANNER too
It seems we forgot this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 84a9aad23..d37814f78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,10 +192,6 @@ if test x$found_introspection != xno; then
AC_SUBST(META_GIR)
fi
-AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
-AS_IF([test "x$WAYLAND_SCANNER" = "xno"],
- AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
-AC_SUBST([WAYLAND_SCANNER])
AC_SUBST(XWAYLAND_PATH)
PKG_CHECK_MODULES(MUTTER, $MUTTER_PC_MODULES)
@@ -208,6 +204,11 @@ AM_CONDITIONAL([HAVE_NATIVE_BACKEND],[test $have_native_backend = yes])
PKG_CHECK_MODULES(MUTTER_WAYLAND, [clutter-wayland-1.0 clutter-wayland-compositor-1.0 wayland-server >= 1.5.90], [have_wayland=yes], [have_wayland=no])
if test $have_wayland = yes; then
+ AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
+ AS_IF([test $WAYLAND_SCANNER = "no"],
+ AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
+ AC_SUBST([WAYLAND_SCANNER])
+
AC_DEFINE([HAVE_WAYLAND],[1],[Define if you want to enable Wayland support])
fi
AM_CONDITIONAL([HAVE_WAYLAND],[test $have_wayland = yes])