summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 69ead4de0..b717004c5 100644
--- a/configure.in
+++ b/configure.in
@@ -415,20 +415,20 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
AC_FUNC_ALLOCA
])
-dnl Check for valid BITS_PER_MP_LIMB and BYTES_PER_MP_LIMB
+dnl Check for valid GMP_LIMB_BITS
+dnl (BYTES_PER_MP_LIMB is defined in mpfr-gmp.h from GMP_LIMB_BITS)
dnl This test doesn't need to link with libgmp (at least it shouldn't).
if test -n "$gmp_internal_file_check" ; then
- AC_MSG_CHECKING(for valid BITS_PER_MP_LIMB and BYTES_PER_MP_LIMB)
+ AC_MSG_CHECKING(for valid GMP_LIMB_BITS)
AC_RUN_IFELSE([AC_LANG_PROGRAM([[
#include <limits.h>
#include "gmp.h"
#include "gmp-impl.h"
]], [[
- return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
- && sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
+ return GMP_LIMB_BITS == sizeof(mp_limb_t) * CHAR_BIT ? 0 : 1;
]])], [AC_MSG_RESULT(yes)], [
AC_MSG_RESULT(no)
- AC_MSG_ERROR([BITS_PER_MP_LIMB or BYTES_PER_MP_LIMB are incorrect.
+ AC_MSG_ERROR([GMP_LIMB_BITS is incorrect.
You probably need to change some of the GMP or MPFR compile options.])],
[AC_MSG_RESULT([can't test])])
fi