summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2018-04-03 13:07:14 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2018-04-03 13:07:14 +0000
commit94eb23cc9004e412ce9bbd0b2e98eab75265d696 (patch)
tree29d986941e811712e3ba6f87efd9ea0124ca7e9f /tests/Makefile.am
parent28bff723c08ce792aa050f94864791af92567942 (diff)
downloadmpfr-94eb23cc9004e412ce9bbd0b2e98eab75265d696.tar.gz
[tests/Makefile.am] Update of the "check" rule:
* Output svnversion info when applicable. * Do not echo "cat tversion.log 2> /dev/null || true". git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@12535 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7c205e8e3..ebb1734db 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -46,7 +46,13 @@ check_PROGRAMS = tversion tabort_prec_max tassert tabort_defalloc1 \
# has been generated with Automake 1.13+); but this is done only when
# no tests fail.
check:
- cat tversion.log 2> /dev/null || true
+ @if [ -d $(top_srcdir)/.svn ]; then \
+ output=`svnversion $(top_srcdir) 2> /dev/null`; \
+ if [ -n "$$output" ]; then \
+ echo "[svnversion] $$output"; \
+ fi; \
+ fi
+ @cat tversion.log 2> /dev/null || true
AM_CPPFLAGS = -DSRCDIR='"$(srcdir)"'