summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-08-02 08:15:24 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-08-02 08:15:24 +0000
commit15956538dcafb5957499c1bf2258e75cfbce148c (patch)
treec26fa90b3f11a3b84282818b0cea710becdcb4ed /src/Makefile.am
parent7dd57386ca54811abe1d81ca6dbd69c473b5c8ce (diff)
downloadmpfr-15956538dcafb5957499c1bf2258e75cfbce148c.tar.gz
Fixed src/get_patches.c generation that was changed in r13542.
* src/Makefile.am, tools/get_patches.sh: since get_patches.sh is no longer run from $(top_srcdir), the PATCHES absolute pathname now needs to be passed in argument. * src/Makefile.am: fixed the get_patches.c rule (the automatic variable $< was used with the meaning "first prerequisite" of GNU Make; an "exit 1" was missing, so that a failure did not abort "make" immediately). * tools/get_patches.sh: detect errors with "set -e". git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13543 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 345743a5f..8bb4d731c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -90,8 +90,10 @@ libmpfr_la_LIBADD = @LIBOBJS@
# 4.0.x 6:x:0
libmpfr_la_LDFLAGS = $(MPFR_LDFLAGS) $(LIBMPFR_LDFLAGS) -version-info 6:0:0
-get_patches.c: $(top_srcdir)/tools/get_patches.sh $(top_srcdir)/PATCHES
- $< > $@ || rm -f $@
+GET_PATCHES_SH = $(top_srcdir)/tools/get_patches.sh
+PATCHES = $(top_srcdir)/PATCHES
+get_patches.c: $(GET_PATCHES_SH) $(PATCHES)
+ $(GET_PATCHES_SH) $(PATCHES) > $@ || { rm -f $@; exit 1; }
if MINI_GMP