summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-01-09 14:25:30 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-01-09 14:25:30 +0000
commitd79a5c630eacf98c86667aa0d2389cd096dea113 (patch)
tree31ce4b22cd0533d5f3c8d125a47d39dce3abafec /configure.ac
parentbfa184c340939ecae2cbcd511cd5c972512bed3b (diff)
downloadmpfr-d79a5c630eacf98c86667aa0d2389cd096dea113.tar.gz
[acinclude.m4] Updated messages about the format of "long double".
[configure.ac] Ditto for "double". Added missing AC_MSG_RESULT. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13661 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 569eb097b..86e033ceb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -413,7 +413,7 @@ dnl This must done before MPFR_CONFIGS.
LT_INIT(win32-dll)
dnl Try to determine the double format
-AC_MSG_CHECKING(format of `double' floating point)
+AC_MSG_CHECKING(format of floating-point type `double')
AC_RUN_IFELSE([AC_LANG_PROGRAM([[
]], [[
union ieee_double_extract
@@ -443,7 +443,8 @@ case "$mpfr_ieee_double" in
AC_DEFINE(HAVE_DOUBLE_IEEE_LITTLE_ENDIAN) ;;
2) AC_MSG_RESULT([IEEE big endian])
AC_DEFINE(HAVE_DOUBLE_IEEE_BIG_ENDIAN) ;;
- *) AC_MSG_WARN([format of `double' floating-point not recognized]) ;;
+ *) AC_MSG_RESULT([unknown])
+ AC_MSG_WARN([format of `double' not recognized]) ;;
esac
dnl Warning: This test is *only* for CFLAGS settings.