summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-07-01 14:12:10 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-07-01 14:12:10 +0000
commitd2929949747da92dcfed5fc7165869638b76d936 (patch)
treecb6e1a582beb3dcda752f2738512797c0f99b9f0 /configure.ac
parentadb5a4fe49c06cf91dd42932e4298bf24c1cc184 (diff)
downloadmpfr-d2929949747da92dcfed5fc7165869638b76d936.tar.gz
[acinclude.m4,configure.ac] For MPFR_C_LONG_DOUBLE_FORMAT, when the
format is unknown and it is detected that LTO has been used, output "recognition prevented by LTO". Note: at the same time, since AC_PROG_FGREP was needed, replaced $EGREP by $FGREP when applicable. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13513 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 40c3f986c..12e6129e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,7 @@ dnl choose a compiler because of the CC and CFLAGS setup from gmp.h!
AC_CANONICAL_HOST
AC_PROG_EGREP
+AC_PROG_FGREP
AC_PROG_SED
dnl To use a separate config header.
@@ -362,13 +363,13 @@ if test -z "$GMP_CC$GMP_CFLAGS" ; then
echo "MPFR_OPTION __GMP_CC" >> conftest.c
$cpp $CPPFLAGS conftest.c 2> /dev/null > conftest.txt
test $? -ne 0 && continue
- GMP_CC=`$EGREP MPFR_OPTION conftest.txt | $SED -e 's/MPFR_OPTION //g;s/ *" *//g'`
+ GMP_CC=`$FGREP MPFR_OPTION conftest.txt | $SED -e 's/MPFR_OPTION //g;s/ *" *//g'`
# Get CFLAGS
echo "#include \"gmp.h\"" > conftest.c
echo "MPFR_OPTION __GMP_CFLAGS" >> conftest.c
$cpp $CPPFLAGS conftest.c 2> /dev/null > conftest.txt
test $? -ne 0 && continue
- [GMP_CFLAGS=`$EGREP MPFR_OPTION conftest.txt | $SED -e 's/[ "]-pedantic[ "]/ /g;s/MPFR_OPTION //g;s/ *" *//g'`]
+ [GMP_CFLAGS=`$FGREP MPFR_OPTION conftest.txt | $SED -e 's/[ "]-pedantic[ "]/ /g;s/MPFR_OPTION //g;s/ *" *//g'`]
break
done
rm -f conftest*