summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-01-09 12:56:20 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-01-09 12:56:20 +0000
commitc6d8e37674e56ce3a93d68dbba1089ecd7790d19 (patch)
tree3732a96317418d3a8866c7adccf05537753f9b58 /configure.ac
parentda20c322ca11c421a48472fb6d7ca6df5d3be8f8 (diff)
downloadmpfr-c6d8e37674e56ce3a93d68dbba1089ecd7790d19.tar.gz
Cleaned up configure code related to threading and the shared cache.
* acinclude.m4: - detect incompatibilities between configure options at the beginning of MPFR_CONFIGS, forcing enable_thread_safe to "no" or "yes" when necessary, so that the subsequent code can rely on that; - check ISO C11 thread support and/or POSIX thread support only when necessary; - handle --enable-shared-cache early in MPFR_CONFIGS, because the use of POSIX threads (pthread) may need to change CC, CFLAGS, and LIBS (thus affecting other tests); - test $enable_shared_cache instead of $mpfr_want_shared_cache; - removed the now useless MPFR_CHECK_SHARED_CACHE function. * configure.ac: no longer set the mpfr_want_shared_cache variable, as enable_shared_cache (now used) already has the same usage. Note: currently, ./configure --enable-shared-cache CFLAGS="-std=c99" still succeeds and still makes the compilation fail. This seems to be due to a limitation of AX_PTHREAD, which just tests linking, not compilation. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13392 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7901ca3a2..412f85fb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,7 +188,7 @@ AC_ARG_ENABLE(shared-cache,
for all MPFR constants. It usually makes MPFR
dependent on PTHREAD [[default=no]]],
[ case $enableval in
- yes) mpfr_want_shared_cache=yes
+ yes)
AC_DEFINE([MPFR_WANT_SHARED_CACHE],1,[Want shared cache]) ;;
no) ;;
*) AC_MSG_ERROR([bad value for --enable-shared-cache: yes or no]) ;;