summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2018-06-23 10:40:02 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2018-06-23 10:40:02 +0000
commitbc65fdecf940eacdea965d3e1642cea8418b8069 (patch)
treedb1c28416fb4c76bf044cc134f6c1fed70112626 /configure.ac
parent93d4bfec8ddb8559cf8245eeb9f10d80ed1c90d2 (diff)
downloadmpfr-bc65fdecf940eacdea965d3e1642cea8418b8069.tar.gz
[configure.ac] Do not do specific CFLAGS settings for MS-Windows ICC.
See <https://sympa.inria.fr/sympa/arc/mpfr/2018-06/msg00027.html>. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@12855 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index eaa83e694..66c4b2047 100644
--- a/configure.ac
+++ b/configure.ac
@@ -404,7 +404,8 @@ AC_ARG_ENABLE(lto,
*) AC_MSG_ERROR([bad value for --enable-lto: yes or no]) ;;
esac])
-dnl If the compiler is ICC, add some specific flags.
+dnl Warning: This test is *only* for CFLAGS settings.
+dnl If the compiler is ICC, add some specific flags, except on MS-Windows.
dnl Don't add warnings flags (Otherwise you'll get more than 20000 warnings).
dnl Add -long_double flags? Don't use -pc64 !
dnl Notes (VL):
@@ -423,10 +424,10 @@ dnl to use -fp-model <arg> instead of -mp, but what is <arg>? Anyway
dnl -mieee-fp solves the tset_d failure due to a negative zero. This
dnl option has been introduced in ICC 9.0 for Linux (2005-06):
dnl http://www.ncsa.illinois.edu/UserInfo/Resources/Software/Intel/Compilers/9.0/C_ReleaseNotes.htm
-AC_MSG_CHECKING(for ICC)
+AC_MSG_CHECKING(for non-MS-Windows ICC)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#if !defined(__ICC) && !defined(__INTEL_COMPILER)
-# error "Not ICC"
+#if (!defined(__ICC) && !defined(__INTEL_COMPILER)) || defined(_WIN32)
+# error "Not a non-MS-Windows ICC"
error
#endif
]], [[]])],[