summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-01-30 09:19:01 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2019-01-30 09:19:01 +0000
commitab2279a252b70a62d3a9a26498df4799838f646f (patch)
tree4cb850a968f77c68aac7b54f7f6430a32db67a80 /configure.ac
parenteac341fa573f6d0b775681a015333459227ca0fc (diff)
downloadmpfr-ab2279a252b70a62d3a9a26498df4799838f646f.tar.gz
Update about CC / CFLAGS settings from GMP (__GMP_CC / __GMP_CFLAGS).
* configure.ac: remove -pedantic unconditionally; since r7044, it was removed only when logging was enabled, as at that time only logging was using C extensions. * NEWS: added a line about this change. * INSTALL: updated the note about CC / CFLAGS, removing the obsolete reference to GMP 4.3.0 at the same time. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13421 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d9c4907d7..2fdb7626b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,11 +298,9 @@ if test -z "$GMP_CC$GMP_CFLAGS" ; then
# Get CFLAGS
echo "#include \"gmp.h\"" > conftest.c
echo "MPFR_OPTION __GMP_CFLAGS" >> conftest.c
- unset rmpedantic
- [test "$enable_logging" = yes && rmpedantic='s/[ "]-pedantic[ "]/ /g;']
$cpp $CPPFLAGS conftest.c 2> /dev/null > conftest.txt
test $? -ne 0 && continue
- GMP_CFLAGS=`$EGREP MPFR_OPTION conftest.txt | $SED -e "$rmpedantic"'s/MPFR_OPTION //g;s/ *" *//g'`
+ [GMP_CFLAGS=`$EGREP MPFR_OPTION conftest.txt | $SED -e 's/[ "]-pedantic[ "]/ /g;s/MPFR_OPTION //g;s/ *" *//g'`]
break
done
rm -f conftest*