summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-06-10 10:21:51 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-06-10 10:21:51 +0000
commit9dbd638ae4c484e7faa51d10f238e1c942be7fa5 (patch)
treecbf23e5dce7ae1e8ce9ae8b58a19ab8266e6e8da /configure.ac
parent3f7f7be7b31f719f266975ca8a9377ad3894adc4 (diff)
downloadmpfr-9dbd638ae4c484e7faa51d10f238e1c942be7fa5.tar.gz
[configure.ac] With mini-gmp, also check the availability of srand48.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13961 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5ef637090..0c9ae5849 100644
--- a/configure.ac
+++ b/configure.ac
@@ -805,9 +805,11 @@ AC_COMPUTE_INT(mini_gmp_numb_bits, [(GMP_NUMB_BITS)],
CPPFLAGS="$saved_CPPFLAGS"
AC_MSG_RESULT([$mini_gmp_numb_bits bits ($how)])
-dnl We need to check the availability of lrand48 (used by random_limb),
-dnl in particular because it is not part of the ISO C standard.
-AC_CHECK_FUNC(lrand48,,AC_MSG_FAILURE([mini-gmp requires lrand48]))
+dnl We need to check the availability of lrand48 (used by random_limb)
+dnl and srand48 (used by gmp_randseed_ui), in particular because these
+dnl functions are not part of the ISO C standard.
+AC_CHECK_FUNC(lrand48,,AC_MSG_FAILURE([MPFR + mini-gmp requires lrand48]))
+AC_CHECK_FUNC(srand48,,AC_MSG_FAILURE([MPFR + mini-gmp requires srand48]))
fi