summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-04-02 13:49:16 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-04-02 13:49:16 +0000
commit30f04419dd90223580337fd32152057a3086c541 (patch)
tree063274b991998dece2704b558f05ac3aea8943f1 /configure.ac
parent8d42b3eec1c2cf6992a0a8d3b86ad6f3ec5c3588 (diff)
downloadmpfr-30f04419dd90223580337fd32152057a3086c541.tar.gz
[configure.ac] Fixed the change done in r13853 (about removed macros),
making the code simpler and more maintainable at the same time. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13861 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 10 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 77e8126f8..ac9caa66e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -808,25 +808,17 @@ dnl End of setup related to GMP / mini-gmp
dnl The getrusage function is needed for MPFR bench (cf tools/bench)
AC_CHECK_FUNCS([getrusage])
-dnl Remove also many MACROS (AC_DEFINE) which are unused by MPFR
-dnl and polluate (and slow down because libtool has to parse them) the build.
+dnl Remove also many MACROS (AC_DEFINE) which are unused by MPFR and
+dnl pollute (and slow down because libtool has to parse them) the build.
if test -f confdefs.h; then
- $SED '/#define PACKAGE_/d' <confdefs.h >confdefs.tmp
- $SED '/#define HAVE_STRING/d' <confdefs.tmp >confdefs.h
- $SED '/#define HAVE_DLFCN_H/d' <confdefs.tmp >confdefs.h
- $SED '/#define HAVE_MEM/d' <confdefs.h >confdefs.tmp
- $SED '/#define STDC_HEADERS/d' <confdefs.tmp >confdefs.h
- $SED '/#define HAVE_STRTOL/d' <confdefs.h >confdefs.tmp
- $SED '/#define HAVE_STDLIB_H/d' <confdefs.tmp >confdefs.h
- $SED '/#define HAVE_UNISTD_H/d' <confdefs.h >confdefs.tmp
- $SED '/#define HAVE_STDC_HEADERS/d' <confdefs.tmp >confdefs.h
- $SED '/#define HAVE_LONG_DOUBLE/d' <confdefs.h >confdefs.tmp
- $SED '/#define HAVE_SYS_STAT_H/d' <confdefs.tmp >confdefs.h
- $SED '/#define HAVE_SYS_TYPES_H/d' <confdefs.h >confdefs.tmp
- $SED '/#define PROTOTYPES/d' <confdefs.tmp >confdefs.h
- $SED '/#define __PROTOTYPES/d' <confdefs.h >confdefs.tmp
-
- mv confdefs.tmp confdefs.h
+ for i in PACKAGE_ HAVE_STRING HAVE_DLFCN_H HAVE_MEM STDC_HEADERS \
+ HAVE_STRTOL HAVE_STDLIB_H HAVE_UNISTD_H HAVE_STDC_HEADERS \
+ HAVE_LONG_DOUBLE HAVE_SYS_STAT_H HAVE_SYS_TYPES_H \
+ PROTOTYPES __PROTOTYPES
+ do
+ $SED "/#define $i/d" < confdefs.h > confdefs.tmp
+ mv confdefs.tmp confdefs.h
+ done
fi
if $EGREP -q -e '-dev$' $srcdir/VERSION; then