summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-04-10 11:19:19 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2020-04-10 11:19:19 +0000
commit1ac2b1ca55ea54a7045c42c532f494b9f7e9bf24 (patch)
tree38c1ae86241cfcbf86fe47a3c8a58d23d4ad4470 /configure.ac
parent9035cc7a9e134d55cf153464d2d8a8bf2f563b67 (diff)
downloadmpfr-1ac2b1ca55ea54a7045c42c532f494b9f7e9bf24.tar.gz
Reworked decimal support and detection, resolving FIXMEs.
* INSTALL, acinclude.m4, configure.ac: --enable-decimal-float can take new values. Change of macro DPD_FORMAT (DPD was assumed in case of cross-compilation, which could be wrong) to 3 new macros: DECIMAL_DPD_FORMAT, DECIMAL_BID_FORMAT, DECIMAL_GENERIC_CODE. * doc/README.dev: documented these 3 new macros. * src/mpfr-impl.h: the detection of the BID encoding can now be done at compile time when GCC defines __DECIMAL_BID_FORMAT__ (as on x86); support of the 3 new macros. * src/{get_d64.c,set_d64.c,set_d128.c}: update. * tests/{tget_set_d64.c,tget_set_d128.c,tversion.c}: update. git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@13878 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ac9caa66e..87f18f923 100644
--- a/configure.ac
+++ b/configure.ac
@@ -236,11 +236,10 @@ dnl --disable-decimal-float would explicitly disable both.
AC_ARG_ENABLE(decimal-float,
[ --disable-decimal-float explicitly disable decimal floats support
--enable-decimal-float build conversion functions from/to decimal floats
- [[default=autodetect]]],
+ (see INSTALL file for details) [[default=auto]]],
[ case $enableval in
- yes) ;;
- no) ;;
- *) AC_MSG_ERROR([bad value for --enable-decimal-float: yes or no]) ;;
+ yes|no|auto|bid|dpd|generic) ;;
+ *) AC_MSG_ERROR([bad value for --enable-decimal-float]) ;;
esac])
dnl Warning! Not to be confused with _Decimal128. Thus it is better